Tuesday, November 16, 2010

XPages Demoapp - Adding controls to a pager

I got a question from a reader regarding posting a demoapp of Adding controls inside a pager

I mocked up a simple demoapp with search controls inside the pager area.


>> Download demoapp

10 comments:

Erik Brooks said...

Cool! Thanks for sharing, as always.

quintessens said...

Just had a discussion yesterday with some developers about view layout. if you look on most examples from the OneUI, mostly 'details views' are being used.

I must say in most occassions view data rows that read like mail (bottom down) are best. (http://www-12.lotus.com/ldd/doc/oneuidoc/docpublic/examples.htm?content=2colDetail.htm)

Tommy Valand said...

Uhm..? :)

Ajit said...

Stunning is the word.

Usha Dewasthali said...

Thanks Tommy, this is very helpful. Someone from the XPage forum pointed me to your blog entry after I posted a question on the site.

When I follow your steps, my edit box is showing up slightly higher than the pager at the left. Any ideas how to get them inline with one another? I looked at your demo database locally and it is the same way where the search box is larger font and appears higher than the pager. I thought it was because of the div tag so I removed it, but that did not help. Your screenshot in the article shows it on the same line so maybe some code or styling was left out of your demo database. Sorry for such a long comment, but if you have any ideas I would greatly appreciate it.

- Usha

Usha Dewasthali said...

Thanks so much for this post. I was trying to figure this out for a while and someone in the XPage forum pointed me to your blog.

Any ideas how to get the custom content inline with the pager on the right? My custom content appears higher than the pager. I would like the two to be inline. I removed the div tag and that didn't help.

I downloaded your demo db and it shows up the same way with the Search Edit Box being higher than the pager to the right. However, your screenshot on the blog showed them inline. Any suggestions for me? Thanks!

Tommy Valand said...

The screenshot is from Firefox 3.6. Which browser are you testing in?

Usha Dewasthali said...

I was using it in IE, but switched to Firefox 3.6 and get the same results. Here is a copy of the code:

Usha Dewasthali said...

sorry it my code could not be pasted because of the tags I think..

Gary Morin said...

Great help. Thanks!